Extractor

Extractor 2.4
© 1994-2003 Nova Software


Čo je to Extractor?

Extractor je program na vyhľadávanie súborov rôznych formátov v zvolených súboroch. Veľkosti nájdených súborov sú vypočítavané podľa obsahu súborov a sú totožné s pôvodnými veľkosťami súborov. Výsledky hľadania môžete jednoducho uložiť a kedykoľvek ich znovu načítať bez nutnosti opätovného prehľadávania súborov. Extractor obsahuje mnoho ďalších funkcií pre prácu so súbormi. Pomocou nich sa dajú súbory extrahovať, ľubovoľne rozdeľovať, zlučovať, importovať či vytvárať groupfily rôznych formátov. Nájdené súbory sa dajú prehliadať a otvárať priamo z programu bez nutnosti extrahovania. Medzi ďalšie funkcie patrí napríklad vyhľadávanie ľubovoľného textu v položkách nájdených súborov či triedenie položiek podľa zadaných kritérií.


Čo je nové?

Extractor 2.4

  • podpora formátu DDS
  • podpora groupfilov 007, APAK, IBF, IRES, MW4
  • vytváranie groupfilu BIG
  • vylepšenie detekcie a zisťovania informácií o formátoch AVI, OGG, WAV
  • oprava detekcie formátov MOV, S3M, SWF, TXT (pridané nastavenie)
  • vylepšenie detekcie a načítania groupfilov BIG (pôvodné meno VIV), CBF, RFA
  • kompletná anglická a francúzska lokalizácia
  • optimalizácia kódu
  • nový multimediálny prehrávač (importovaný MediaPlayer)
  • pridaná možnosť importu súboru ako odkaz na súbor na disku (dáta zdrojového súboru sa nezmenia, zmení sa iba meno zdrojového súboru nájdeného súboru, pozícia a jeho veľkosť), vhodné pri vytváraní groupfilov
  • prehratie súborov do hlavného okna programu so stlačenou klávesou Ctrl alebo Shift funguje ako pridanie týchto súborov do zoznamu
  • ďalšie opravy a vylepšenia (detekcie groupfilov, report, ...)

Extractor 2.34

  • podpora formátu PDF
  • podpora groupfilu AST
  • vylepšenie detekcie formátov ICO, MPG, TGA
  • pridaná možnosť zmeny pozície prehľadávania aktuálneho súboru kurzorom myši v oblasti indikátora priebehu
  • plná podpora vizuálnych štýlov Windows XP
  • drobné opravy a vylepšenia

Extractor 2.33

  • podpora formátu TIF
  • podpora groupfilov LDAT, RFA, SRSC
  • oprava načítania groupfilov U (problémy u novšej verzie UT2003)
  • vylepšená správa formátov

Extractor 2.32

  • podpora groupfilov DRS, LIB, NPAK, TRWAD, U (a príbuzných UNR, UMX, UAX, UTX, ...)
  • vytváraie groupfilov RAR, ZIP

Extractor 2.3

  • podpora vstupných pluginov formátov a groupfilov a výstupných pluginov groupfilov
  • podpora formátov JP2, TXT a groupfilov BCP, MIX (formát C&C Renegade), SCM, VDF
  • vytváranie groupfilu GRP
  • vylepšenie načítania groupfilu PBO
  • nová verzia API 1.1, pozmenené niektoré štruktúry a funkcie, pridaná podpora pluginov pre vytváranie groupfilov
  • kompletná slovenská lokalizácia (program i nápoveda)
  • optimalizácia vyhľadávania formátov
  • plne dynamická správa formátov - zvýšenie rýchlosti hľadania v závislosti od počtu hľadaných formátov, čím menej formátov sa vyhľadáva, tým je zvýšenie rýchlosti hľadania výraznejšie
  • oprava a vylepšenie detekcie formátov ICO, MP3 (menej falošných poplachov - rýchlejšie vyhľadávanie), OGG (teraz podporuje ľubovoľné formáty streamov - audio, video)
  • podpora vizuálnych štýlov Windows XP
  • integrácia do systému
  • nová verzia formátu ESR pre uloženie výsledkov hľadania, výsledný súbor je niekoľkonásobne menší
  • rôzne štýly zobrazovania položiek nájdených súborov
  • drag & drop operácie s položkami súborov teraz fungujú ako presunutie (skôr fungovaly ako zámena položiek)
  • drobné opravy a vylepšenia prehliadača súborov
  • v registračnom formuláre zkrátená dĺžka variabilného symbolu na 10 znakov (z dôvodu kompatibility s niektorými bankami, internetovým a mobilným bankovníctvom)
  • zaznamenávanie chýb do súboru error.log
  • opravená a vylepšená správa jazykových súborov
  • ďalšie drobné opravy a vylepšenia

Extractor 2.22

  • podpora playlistu (formát APL) programu Game Audio Player (GAP)
  • opravy chýb (program padal pri výbere veľkého počtu súborov na prehliadanie - chyba Windows, opravy dialógov, ...)

Extractor 2.21

  • opravy chýb (voliteľná cache, čítanie výsledkov hľadania, chyby v súvislosti so skinmi vo Windows XP, ...)

Extractor 2.2

  • podpora groupfilov DUN, REZ
  • kompletná renovácia čítania (detekcie), zápisu a správy formátov a groupfilov
  • prehľadávané súbory sa dajú zadávať ľubovoľným spôsobom:
    "C:\Dokumenty\" - budú prehľadané všetky súbory v adresárovej štruktúre C:\Dokumenty\
    "C:\Dokumenty\*.dat" - budú prehľadané všetky súbory typu *.dat v adresáre C:\Dokumenty\
    "C:\Dokumenty\súbor.dat" - bude prehľadaný súbor C:\Dokumenty\súbor.dat
  • do zoznamu nájdených súborov sa teraz dajú pridávať okrem jednotlivých súborov aj celé adresárové štruktúry z disku (vhodné na vytváranie groupfilov)
  • opravy a vylepšenia interného prehliadača (zobrazovanie médií, chyby pri zobrazovaní BMP obrázkov, prepínanie módov...)
  • vylepšená podpora Internetu
  • ďalšie drobné opravy

Extractor 2.11

  • oprava a vylepšenie interného prehliadača
  • ďalšie drobné opravy

Extractor 2.1

  • podpora formátov 3DS, X
  • oprava a vylepšenie načítania groupfilu VPP
  • opravy drobných chýb

Extractor 2.0

  • kompletná lokalizácia programu
  • podpora formátov EAMUS, HMP, SEC, STY, OGG
  • podpora groupfilov ADAT, BAG, EIRES, GZP, HOG, LOD, MHW, PBO, RFF, RUS, SAD, VPP
  • vytváranie groupfilov Half-Life wad (WAD) a Operation Flashpoint groupfile (PBO)
  • oprava a vylepšenie detekcie formátov AIF, ASF, AU, HMI, IFF, MPG, VOC, WAV
  • zvýšenie rýchlosti hľadania o 10% oproti verzii 1.8
  • premenné označenie jednotky CD-R pri ukladaní výsledkov hľadania, označenie jednotky sa pri načítaní výsledkov hľadania prizpôsobuje aktuálnemu označeniu
  • triedenie položiek podľa zadaných kritérií (meno, typ, pozícia, veľkost, poznámka v vzostupnom alebo zostupnom poradí)
  • vloženie ľubovoľných súborov z disku do zoznamu nájdených súborov
  • vylepšenie prehliadača súborov, grafické a multimediálne súbory sa dajú prehliadať priamo v programe
  • farebné pozadie položiek nájdených súborov
  • prehľadávané súbory sa dajú zadávať súborovou maskou (napr.: "C:\Data\*.dat")
  • HTML nápoveda
  • opravy chýb a ďalšie drobné vylepšenia

Extractor 1.8

  • podpora groupfilov DNI, RES, STG
  • oprava a vylepšenie detekcie formátov ASF (formát WMA bol presunutý pod ASF), WAV
  • opravy chýb (správa ikon a formátov, funkcie Otvoriť, opravy textov, ...)

Extractor 1.7

  • podpora groupfilov PKR, POD, WDIR
  • oprava a vylepšenie detekcie formátov MP3, MPG, SWF, WMA, WAV
  • oprava funkcie Otvoriť
  • možnosť zobrazenia nájdeného súboru
  • oprava read-only módu programu
  • ikony typov súborov
  • opravy ďalších programových a vizuálnych chýb

Extractor 1.6

  • podpora formátov DLS, FORM, PAL, RIFF, RMI, SGT
  • podpora groupfilov DTA, PFF, WTN, ZWP
  • oprava a vylepšenie detekcie formátov BIK, HMI, IT, MOD, MP3, MUS, XMI a všetkých groupfilov
  • zvýšenie rýchlosti hľadania o 40%
  • možnosť vytvárania groupfilov (zlúčenie súborov, Quake pack, Aliens vs. Predator fastfile)
  • podpora výsledkov hľadania vo formáte CSV (reťazce oddelené bodkočiarkou)
  • vylepšenie automatickej veľkosti cache, teraz zrýchluje hľadanie oproti konštantnej veľkosti
  • oprava počiatočnej pozície hľadania
  • mnoho ďalších nových volieb na stránke Nastavenie
  • opravy drobných chýb

Extractor 1.5

  • podpora formátov ASF, MNG, MP3, MPG, RA, RM, SMK, SWF, TGA
  • podpora groupfilov CBF, DIR, FFL, FFS, GOB, HAL, LAB, VIV, PAK, XCR
  • oprava a vylepšenie detekcie formátov AIF, ANI, AUD, AVI, BIK, BMP, FLC, FLI, GIF, IFF, IT, LBM, JPG, MOD, MOV, MTM, PCX, PNG, S3M, VOC, VQA, WAV, XM, XMI
  • výrazné zrýchlenie hľadania, rýchlosť teraz závisí od počtu hľadaných formátov
  • výhodnejšie podmienky registrácie
  • import externého súboru do prehľadávaného (zdrojového) súboru
  • uloženie a načítanie výsledkov hľadania
  • pridávanie a mazanie položiek nájdených súborov
  • globálne vyhľadávanie v zozname nájdených súborov
  • súhrnné informácie o priebehu hľadanie - Report
  • oprava funkcie Otvoriť
  • zobrazenie pozície a veľkosti nájdených súborov v hexadecimálnom tvare
  • odhad času dokončenia hľadania (mnoho tvarov)
  • pomenovanie nájdených súborov podľa zdrojového súboru
  • uloženie a načítanie označených formátov a groupfilov
  • oprava označenia nájdených súborov pomocou masky
  • nápoveda vo formáte HLP
  • ďalšie drobné opravy a vylepšenia

Extractor 1.2

  • možnosť prehľadávania viacej súborov naraz
  • oprava funkcie Otvoriť
  • výber nájdených súborov pomocou masky
  • oprava detekcie formátov GIF
  • história položiek
  • voliteľná veľkosť prehľadávacieho okna

Extractor 1.1

  • oprava detekcie formátov MID a VOC
  • opravy a vylepšenia vyhľadávacieho enginu a ovládanie
  • nový design a informatívne prvky

Extractor 1.02

  • drobné opravy

Extractor 1.01

  • drobné opravy

Extractor 1.0

  • podpora 33 základných formátov
  • prvá oficiálna verzia


Postup pri práci s programom

1) Najprv vyberte súbory, ktoré chcete prehľadávať, pomocou tlačidla Vybrať alebo zadajte ich mená v poli Prehľadávané súbory. Pri zadávaní viacerých súborov musí byť každé meno súboru oddelené znakom " z oboch strán.

2) Vyberte adresár na ukladanie súborov tlačidlom Vybrať alebo zadajte jeho meno v poli Adresár na ukladanie súborov. Pokiaľ adresár neexistuje, program ho automaticky vytvorí.

3) Označte formáty súborov (stránka Formáty), ktoré chcete hľadať, v zozname Hľadať formáty. Ďalej môžete označiť groupfily v zozname Akceptovať groupfily (stránka Groupfily). Pokiaľ Extractor nájde štruktúru groupfilu, ktorý je povolený, bude súbory vyhľadávať iným, značne rýchlejším spôsobom.

4) Vlastnosti programu a hľadanie môžete doladiť na stránke nastavenie.

5) Pre zahájenie prehľadávania stlačte tlačidlo Štart.

6) Počas alebo po ukončení prehľadávania môžete nájdené súbory spustiť (programom asociovaným k danej prípone) stlačením tlačidla Otvoriť alebo si ho pozrieť pomocou klávesy F5, ďalej je možné použiť niektoré z ďalších funkcií pomocou tlačidla Funkcie.

7) Nájdené súbory môžete extrahovať. Požadované súbory označte zaškrtnutím políčka vedľa názvu súboru alebo použite tlačidlá +, -, Inv. Označené súbory potom extrahujte do zvoleného adresára pomocou tlačidla Extrahovať.


Formáty a groupfily

Podporované formáty a groupfily

Formáty

Typ | Popis | Podpora | Špecifický výskyt
3DS | 3D Studio File | 3D Studio |
AIF | AIFF Sound File | CoolEdit, GoldWave |
ANI | Windows Animate Cursor | Windows |
ASF | Advanced Streaming Format File | Windows Media Player, BSPlayer |
AU | AU Sound File | CoolEdit, GoldWave |
AUD | Westwood Audio File | Game Audio Player, Winamp | C&C, Dune 2000
AVI | Windows Video |  |
BIK | Bink Video | RAD Video Tools |
BMP | Windows/OS2 Bitmap |  |
CUR | Windows Cursor | ACD See, Windows |
DDS | Direct Draw Surface | DirectX Texture Tool | DirectX hry
DLS | Downloadable Sounds File | Awave Studio |
EAMUS | Electronic Arts Audio File | Game Audio Player | Need for Speed
FLC | Autodesk Animator File |  |
FLI | Autodesk Animator File |  |
FORM | Obecný formát FORM |  |
GIF | Graphics Interchange Format |  |
HMI | Human Machine Interface Midi File | Winamp |
HMP | Human Machine Interface Midi File | Winamp |
ICO | Windows Icon | ACD See, PictView |
IFF | 8bit SVX Sound File | CoolEdit, GoldWave |
IT | ImpulseTracker Module | Impulse Tracker, Winamp |
JP2 | JPEG 2000 | IrfanView |
JPG | JPEG File Interchange Format |  |
LBM | Deluxe Paint Bitmap |  |
MID | Musical Instrument Digital Interface |  |
MNG | Animation Shop Animation | Animation Shop |
MOD | ProTracker, Fasttracker Module |  |
MP3 | MPEG Layer 3 |  |
MPG | Motion Picture Experts Group |  |
MOV | QuickTime Movie | QuickTime MoviePlayer |
MTM | MultiTracker Module | Winamp, Impulse Tracker |
MUS | Doom Midi File | Winamp | Doom
OGG | Vorbis File | GoldWave, Winamp |
PAL | Microsoft Palette | Paint Shop Pro |
PCX | Zsoft Painbrush Bitmap |  |
PDF | Adobe Acrobat Document | Adobe Acrobat |
PNG | Portable Network Graphics |  |
RA | RealAudio | RealPlayer |
RIFF | Obecný formát RIFF |  |
RM | RealMovie | RealPlayer |
RMI | RIFF Midi File |  |
S3M | ScreamTracker Module | Scream Tracker, Winamp |
SCX | ColoRix Image File | PictView |
SEC | DirectMusic Segment | DML | Blood 2, Shogo
SGT | DirectMusic Segment Chunk | DML, DM-Player | Drakan, Blood 2, Shogo, NOLF
SMK | Smacker Video File | RAD Video Tools |
STY | DirectMusic Style | DML | Blood 2, Shogo
SWF | Shockwave Flash | Macromedia Flash, RealPlayer |
TGA | Truevision Targa Bitmap |  |
TIF | Tagged Image File Format |  |
TXT | Text File |  |
VOC | Creative Voice File | CoolEdit, GoldWave |
VQA | Westwood Movie File | MixViewer | C&C, Dune 2000
WAV | Windows Wave File |  |
X | DirectX File | DirectX |
XM | Extended Module | Fasttracker, Winamp |
XMI | Extended Midi File | Winamp | hry s Miles Sound Systemem

Poznámka

U bežných formátov nieje uvedený výskyt ani program, ktorý ho podporuje.

Groupfily

Čítanie:

Typ | Popis | Výskyt
007 | James Bond 007: Nightfire directory | James Bond 007: Nightfire
ADAT | Anachronox pack | Anachronox
APAK | Archangel pack | Archangel
AST | Highland Warriors groupfile | Highland Warriors
BAG | Emperor: Battle for Dune bag | Emperor: Battle for Dune
BCP | Warrior Kings pack | Warrior Kings
BIG | EA Big File | EA Sports NHL, Need For Speed: Porsche Unleashed, Need For Speed: Hot Pursuit 2, Command & Conquer Generals
BIN | Chasm pack | Chasm
CBF | Pterodon big file | Flying Heroes, Vietcong
DIR | Commandos directory | Commandos, Commandos: Beyond the Call of Duty
DNI | realMYST directory | realMYST
DRS | Age of Empires groupfile | Age of Empires, Age of Empires II
DTA | Hidden & Dangerous groupfile | Hidden & Dangerous
DUN | Frank Herbert's Dune pack | Frank Herbert's Dune
EIRES | Evil Islands pack | Evil Islands
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
FFS | Forge File System | Quadrax
GOB | LucasArts pack | Dark Forces, Jedi Knight
GRP | Duke Nukem 3D pack | Duke Nukem 3D, Shadow Warrior, Redneck Rampage
GZP | Giants pack | Giants
HAL | Mortyr groupfile | Mortyr
HOG | Descent 3 groupfile | Descent 3
IBF | Iron Storm Big File | Iron Storm
IRES | Innerloop Studios resource file | Project IGI, Project IGI2: Covert Strike
LAB | Outlaws groupfile | Outlaws
LDAT | Poselství trůnu 2: Legenda pack | Poselství trůnu 2: Legenda
LIB | Cultures groupfile | Cultures, Cultures 2
LOD | Heroes of Might and Magic 3 groupfile | Heroes of Might and Magic 3
MHW | Moorhuhn Winter-Edition groupfile | Moorhuhn Winter-Edition
MIX | Westwood groupfile | Command & Conquer, Command & Conquer: Renegade
MW4 | MechWarrior 4: Mercenaries groupfile | MechWarrior 4: Mercenaries
NPAK | Neocron pack | Neocron
PACK | Quake pack | Quake, Quake II, Half-Life, Kingpin, Soldier of Fortune, Daikatana
PAK | Robo Rumble pack | Robo Rumble
PBO | Operation Flashpoint groupfile | Operation Flashpoint
PFF | NovaLogic pack | Delta Force Land Warrior, Delta Force - Black Hawk Down
PKR | Tony Hawk's Pro Skater 2 pack | Tony Hawk's Pro Skater 2
POD | Nocturne pack | Nocturne, Blair Witch I, Blair Witch II
RES | Rage of Mages pack | Rage of Mages, Rage of Mages 2: Necromancer
REZ | LithTech Resource File | Blood2, Shogo, No One Lives Forever, No One Lives Forever 2, Aliens vs. Predator 2
RFA | Digital Illusions pack | Battlefield 1942, RalliSport Challenge
RFF | Blood pack | Blood
RUS | Sudden Strike groupfile | Sudden Strike
SPAK | Sin pack | Sin
SRSC | Drakan resource file | Drakan
SAD | Black & White groupfile | Black & White
SCM | ICQ Sound Scheme | ICQ
STG | Vampirjagd groupfile | Vampirjagd, Vampirjagd 2
TRWAD | Tomb Raider 3 wad | Tomb Raider 3
U | Unreal package | Unreal, Unreal 2, Unreal Tournament, Unreal Tournament 2003, DeusEx, Rune, The Wheel Of Time, Klingon Honor Guard, Deep Space Nine, Undying, X Com Enforcer, Nerf Arena Blast
VDF | Gothic groupfile | Gothic
VPP | Volition groupfile | Summoner, Red Faction
WAD | Doom/Half-Life wad | Doom, Doom II, Half-Life
WDIR | Worms pack | Worms 2, Worms Armageddon
WTN | Witan Entertainment groupfile | Moorhuhn 2
XCR | Warlords Battlecry groupfile | Warlords Battlecry
ZWP | Dark Reign 2 pack | Dark Reign 2

Vytváranie:

Typ | Popis | Formát
*.* | Zlúčenie súborov |
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
GRP | Duke Nukem 3D pack | Duke Nukem 3D
PACK | Quake pack | Quake
PBO | Operation Flashpoint groupfile | Operation Flashpoint
RAR | RAR archive | RAR 2.0
WAD | Half-Life wad | Half-Life
ZIP | ZIP archive | ZIP 1.0

Pokiaľ nájdete nejaký formát alebo groupfile, ktorý Extractor nepodporuje, pošlite o ňom informáciu (popr. jeho popis alebo URL adresu, kde sa nachádza) na adresu autora.

O tom, ako sa dá vykonávať hľadanie efektívne a o množstve ďalších informácií o Extractore sa dočítate v sekcii Tipy.

Odkazy

ACD See
Animation Shop
Awave Studio
BSPlayer (1), (2)
CoolEdit
Deus ex Machina
DML
DM-Player
Game Audio Player (1), (2)
GoldWave
Impulse Tracker
MixViewer
Paint Shop Pro
PictView
QuickTime MoviePlayer
RAD Video Tools
RealPlayer
Winamp
Windows
Windows Media Player

Poznámka

Niektoré formáty vyžadujú pluginy, ktoré nie sú súčasťou inštalácie, dajú sa však samostatne stiahnuť na stránke príslušného programu.


Klávesové skratky

F1 | nápoveda
hlavné okno:
F2 | výber adresára na ukladanie súborov
F3 | výber súborov na prehľadávanie
F5 | štart prehľadávania vybraných súborov
Alt+X | ukončenie programu
prehľadávacie okno:
Alt+X | ukončenie prehľadávania, zavretie okna
F3 | zobraziť súbor
F5 | extrahovať označené súbory
F7 | hľadať text
Shift+F7 | hľadať ďalší text
Ctrl+T | formát času
Ctrl+I | import súboru
Ctrl+G | vytvoriť groupfile
Ins | pridať novú položku
Ctrl+Ins | pridať súbory z disku do zoznamu
Del | zmazať vybrané položky
F6 | premenovanie/presun vybraných položiek
Ctrl+R | správa o hľadaní
Ctrl+S | uloženie výsledkov hľadania
zoznam nájdených súborov:
Alt+Enter | vlastnosti súboru
Enter | otvorenie súboru
Ctrl+A | výber všetkých súborov
Ctrl+N | zrušenie výberu všetkých súborov
zobrazenie súboru:
Esc | zavretie okna
1,2,3,4 | prepínanie módov zobrazení súboru
C | prepínanie zobrazení znakov 0-31
F | vyplniť obrázkom okno
B | bilineárne filtrovanie obrázkov


Terminológia

Terminológia (v rámci Extractoru)

Označenie - zaškrtnutie políčka vedľa mena položky
Výber - inverzné zobrazenie položky
Vyznačenie - výber pomocou prerušovanej čiary okolo položky (focus)
Extrahovanie - skopírovanie časti zdrojového súboru do iného samostatného súboru
Groupfile - súbor, ktorý obsahuje ďalšie súbory (obdoba archívov, ale väčšinou bez kompresie)


Chyby

O prípadných chybách programu informujte prosím autora.

Popis chyby by mal obsahovať nasledujúce náležitosti:

  • verziu programu, pokiaľ možno kompletnú (napr.: 1.5.6.436 alebo 1.5 Beta 4)
  • podrobný popis situácie, kedy chyba nastala (napr.: Chyba nastala pri prehľadávaní súboru file.dat (súčasť programu X), keď bol testovaný formát MPG. Nebolo zobrazené žiadne chybové hlásenie, program prestal odpovedať, bolo ho treba násilne ukončiť pomocou Správcu úloh. Chyba sa opakovala aj pri ďalšom prehľadávaní.)
  • verziu operačného systému a hardwarovú konfiguráciu počítača
  • popr. zoznam programov, ktoré bežali v dobe, keď chyba nastala

Poznámka

Niekedy sa môže stať, že program neurčí správne dĺžku nájdeného súboru. To však nemusí byť vždy chybou Extractora, ale napríklad chybou programu, ktorý nájdený súbor vytvoril. Bolo nájdených už mnoho súborov, ktoré obsahovali poškodené informácie. Pokiaľ je nájdený súbor s chybnými informáciami a vy sa ich pokúsite otvoriť alebo extrahovať, môže sa stať, že program ohlási chybu pri čítaní súboru. To môže byť spôsobené jednak chybou média, na ktorom sa súbor nachádza, alebo práve chybne určenou dĺžkou súboru. V tomto prípade sa môžete pokúsiť opraviť chybu manuálne zmenou veľkosti súboru vo vlastnostiach súboru.


Tipy

Ako dosiahnuť vyššiu rýchlosť hľadania?

  • Najvyššiu rýchlosť hľadania dosiahnete pri vyhľadávaní najmenšieho počtu formátov, pričom každý formát je rôzne náročný na rozpoznanie a preto aj rôzne ovplyvňuje rýchlosť hľadania. Najnáročnejšia detekcia a najdlhšia doba hľadania postihuje streamové formáty (najviac MP3), u ktorých je niekedy veľmi ťažké určiť, či sa jedná o hľadaný súbor alebo o náhodnú kombináciu dát. Z týchto dôvodov je treba zvážiť, ktoré formáty budete vyhľadávať.
  • Akceptácia groupfilov vôbec nepredlžuje dobu hľadania, naopak ich povolením môžete hľadanie výrazne urýchliť a naviac získať pravé mená súborov, ktoré prehľadávaný groupfile obsahuje.
  • Rýchlosť hľadania je možné tak isto zvýšiť povolením automatickej veľkosti vyrovnávacej pamäti (cache). Program obsahuje optimalizáciu pre dynamickú zmenu veľkosti cache, ktorá zvyšuje rýchlosť hľadania súborov.
  • Citeľne vyššiu rýchlosť hľadania dosiahnete pod operačnými systémami vetvy NT, t.j. Windows NT, Windows 2000 a Windows XP

Súborové formáty ako groupfily

  • Niektoré súborové formáty ako sú napríklad PDF alebo SWF sa nemôžu chovať podobne ako groupfily a obsahovať ďalšie súbory najrôznejších formátov (JPG, MP3, ...). Treba si preto uvedomiť, že pokiaľ sú všetky tieto uvedené formáty vybrané na vyhľadávanie, majú prednosť tie, ktoré budú nájdené najskôr (čo sú v tomto prípade hostiteľské súbory PDF a SWF), formáty obsiahnuté vnútri týchto súborov nebudú nájdené (resp. budú preskočené). Toto sa dá odstrániť zakázaním voľby Rýchle hľadanie (Nastavenie/Možnosti), potom budú nájdené všetky formáty vrátane tých, ktoré súbory PDF a SWF obsahujú. Nevýhodou tohto spôsobu však je spomalenie prehľadávania súborov.

Otváranie súborov

  • Pri otváraní súborov z Extractoru sa môže stať, že sa nájdený súbor neotvorí, aj keď sa manuálne otvorenie priamo z programu, ktorý formát podporuje, dá bez problémov. V tomto prípade môže byť na vine chybná asociácia typu súboru k určitému programu. Asociácia by mala byť zapísaná v registri v sekcii HKEY_CLASSES_ROOT\...\shell\open\command nasledovne: ”[meno súboru]” ”%1”. Pokiaľ nie sú uvedené úvodzovky pri symbole parametru %1 a je otváraný súbor s názvom obsahujúcim medzeru (napr.: Sound 00001.wav), potom je parametrom prvá časť súboru do medzery (Sound).

Kontrola nových verzií programu

  • Ak používate telefonické pripojenie k Internetu, máte zapnutú funkciu "Zistiť dostupnosť novej verzie" a používate prehliadač Internet Explorer, môže sa stať, že ste pri stave Offline vyzvaný na pripojenie sa k Internetu (objaví sa dialógové okno "Pripojiť"). Toto sa dá odstrániť tým, že v programe Internet Explorer v menu Nástroje/Možnosti siete Internet.../Pripojenie/Nastavenie telefonického pripojenie zvolíte možnosť Nikdy nevytáčať pripojenie.

Konfiguračný súbor Extractor.ini

  • Konfiguračný súbor Extractor.ini je vytvorený v adresároch podľa nasledujúceho poradia (pokiaľ ho nieje možné vytvoriť, použije sa ďalšia možnosť):
    1. v adresáre s programom
    2. v aktuálnom adresáre
    3. vo Windows adresáre
    4. v koreňovom adresáre disku C
    5. súbor nebude vytvorený


Autorské práva

Program Extractor je chránený autorským právom, o jeho používaní a šírení rozhoduje podľa zákona č. 121/2000 Zb. jeho autor.
Program je distribuovaný ako shareware, v tejto podobe je ho možné voľne šíriť. Sharewarová (neregistrovaná) verzia obsahuje oproti registrovanej verzii niektoré obmedzenia. Ak chcete získať plnohodnotnú verziu bez obmedzenia, je nutné program zaregistrovať.
Po zaregistrovaní (zadaní registračného textu a kódu) sa z programu stane plnohodnotná verzia, ktorej ďalšie šírenie je zakázané. Šírenie registračného textu a kódu nieje povolené, registračný text a kód môže používať iba registrovaná osoba, firma či organizácia. Je zakázané prenikať do štruktúry programu alebo ho dekompilovať či pozmeňovať.
Jednoužívateľská registrácia platí pre jediného užívateľa a počítač, multiregistrácia pre firmy a organizácie pre neobmedzený počet užívateľov a počítačov. Podrobnosti o registrácii programu Extractor nájdete v sekcii Registrácia.


Obmedzenie sharewarovej verzie

  • maximálne 30 nájdených súborov
  • nedá sa používať počiatočná pozícia hľadania a rýchlá zmena pozície kurzorom myši


Registrácia

Registrácia pre Slovenskú republiku

Čo získate registráciou?
  • Plnohodnotnú verziu programu
  • Všetky ďalšie updaty a nové verzie programu zadarmo
  • Technickú podporu, informácie o nových verziách programu

Program Extractor je možné zaregistrovať nasledujúcimi spôsobmi:

Bankovým prevodom:
V pobočke banky požiadajte o poukážku pre bezhotovostný prevod na územie cudzieho štátu. Zameňte Sk na Kč podľa aktuálneho kurzu tak, aby sa čiastka po prevode rovnala príslušnému registračnému poplatku. Túto čiastku preveďte na konto 8002490257/0100 vedené v Komerčnej banke, Česká republika, meno účtu Václav Nováček. Ako variabilný symbol uveďte číslo, ktoré bolo odvodené v okne O programe/Registračný formulár. Ak nebude uvedený variabilný symbol platby, nebude možné platbu identifikovať.
Súčasne s uhradením registračného poplatku odošlite správne vyplnený registračný formulár. Akonáhle bude potvrdená úhrada platby na účte, budú vám zaslané registračné informácie, ktorými program Extractor zaregistrujete v dialógu O programe/Registrácia.

Poštovnou poukážkou typu A alebo A-V:
Príslušný registrační poplatok uhraďte poštovnou poukážkou typu A alebo A-V na konto 8002490257/0100 vedené v Komerčnej banke, meno účtu Václav Nováček. Ako variabilní symbol uveďte číslo, ktoré bolo odvodené v okne O programe/Registračný formulár. Ak nebude uvedený variabilný symbol platby, nebude možné platbu identifikovať.
Súčasne s uhradením registračného poplatku odošlite správne vyplnený registračný formulár. Akonáhle bude potvrdená úhrada platby na účte, budú vám zaslané registračné informácie, ktorými program Extractor zaregistrujete v dialógu O programe/Registrácia.

Poštovnou poukážkou typu C:
 Na adresu autora Václav Nováček, Bolešiny 55, 33901 Klatovy zašlite zloženkou typu C príslušný registračný poplatok. Na zadnú stranu druhého dielu zloženky napíšte meno a verziu programu (napr. Extractor 1.8). Pokiaľ chcete zaslať registračné informácie emailom, napíšte aj vašu emailovú adresu a heslo Registrácia emailom. V opačnom prípade budú registračné informácie zaslané papierovou poštou a obdržíte ich s určitým oneskorením oproti emailu. Spätne obdržíte registračný text a kód, ktorým program Extractor zaregistrujete v dialógu O programe/Registrácia.

Doba vykonania registrácie sa pohybuje okolo 1 až 2 týždňov. Pokiaľ však neobdržíte registračné informácie do jedného mesiaca, obráťte sa prosím na adresu autora (pokiaľ možno formou emailu).

Upozornenie: Program Extractor sa nedodáva spolu s registračným kódom, ale je dostupný na Internete alebo na iných médiách.

Cena jednoužívateľskej registrácie programu je 200 Kč, multiregistrácie pre firmy a organizácie 1000 Kč.

Ďalšie dôležité informácie nájdete v sekcii Autorské práva.


Updaty

Tak ako každý program, tak aj Extractor nieje úplne dokonalý a môže obsahovať chyby. Na odstránenie týchto drobných nedostatkov a rozšírenie programu o nové funkcie slúžia tzv. updaty. Pre riadne zaregistrovaného užívateľa sú funkčné bez obmedzenia a preto nemusí neustále platiť za ten istý program. Ak si zaregistrujete aktuálnu verziu, máte zadarmo všetky budúce verzie. Ako je vidieť, registrácia programu Extractor sa naozaj oplatí.


Autor

Nova Software
Václav Nováček
Bolešiny 55
339 01 Klatovy
Česká republika

Web: http://www.volny.cz/nova-software
Email: nova-software@volny.cz