Extractor

Extractor 2.4
© 1994-2003 Nova Software


Qu'est ce qu'Extractor?

Extractor est un programme qui permet de rechercher des types de formats dans différent fichiers sélctionnés. La taille des fichiers trouvés est calculée selon leur contenu et est identique à leur taille originale. Il est très facile de sauvegarder les résultats de recherches et d'y accéder plus tard sans refaire tout le procesus de recherche à nouveau. Extractor contient beaucoup d'autres fonctions utiles :il peut être utilisé pour extraire, diviser, fusionner ou importer des fichiers et créer des groupes de fichiers de formats variés. Les fichiers trouvés peuvent être ouverts sans avoir besoin d'être extraits. Une des fonctions d'Extractor vous permet de chercher un texte de façon arbitraire dans un des objets trouvés, ou de classer ces objets selon un critere donné.


Quoi de neuf?

Extractor 2.4

  • Support du format DDS
  • Support des groupes de fichiers 007, APAK, IBF, IRES, MW4
  • Création du groupe de fichier BIG
  • Améliorations de la détection d'informations pour les formats AVI, OGG, WAV
  • Amélioration de la détection des formats MOV, S3M, SWF, TXT (Configuration ajoutée)
  • Amélioration de la détection et du chargement des groupes de fichiers BIG (anciennement VIV), CBF, RFA
  • Localisation complète en Anglais et Français
  • Optimisation du code
  • Nouveau lecteur multimedia (MediaPlayer importé)
  • Ajout de la possibilité d'importer un fichier comme référence vers un fichier sur le disque dur (Les données du fichier source ne changeront pas, seuls les noms, positions et taille du fichier source changeront), utile lors de la création de groupes de fichiers
  • Faire glisser/deposer des fichiers dans la fenêtre principale tout en maintenant les touches Ctrl et Shift ajoute ces fichiers à la liste
  • Autres corrections et améliorations (détection des groupes de fichiers, rapport, ...)

Extractor 2.34

  • Support du format PDF
  • support du groupe de fichiers AST
  • Détection des formats ICO, MPG, TGA
  • Ajout de la possibilité de changer la position de la recherche courante d'un fichier en utilisant le pointeur de la souris dans la barre de progression
  • Support complet des styles visuels de Windows XP
  • Autres petites corrections et améliorations

Extractor 2.33

  • Support du format TIF
  • Support des groupes de fichier LDAT, RFA, SRSC
  • Corrections dans le décompte du groupe de fichier U (probleme avec UT2003)
  • Améliorations du contrôle des formats

Extractor 2.32

  • Support des groupes de fichiers DRS, LIB, NPAK, TRWAD, U (appelés autrement UNR, UMX, UAX, UTX, ...)
  • Création des groupes de fichiers RAR et ZIP

Extractor 2.3

  • Vérification des formats d'entrée, des groupes de fichiers ainsi que des plugins des groupes de fichiers de sortie
  • Support des formats JP2, TXT et des groupes de fichiers BCP, MIX (format C&C Renegade), SCM, VDF
  • Création du groupe de fichiers GRP
  • Amélioration du décompte du groupe de fichiers PBO
  • Nouvelle version de API 1.1, certaines structures et fonctions ont changé,création de plugins pour les groupes de fichiers
  • Localisation complète en Slovaque (programme et aide)
  • Optimisation de la recherche de formats
  • Contrôle completement dynamique des formats, la vitesse de recherche est ajustée suivant le nombre de formats recherchés (moins de formats recherchés, vitesse plus grande)
  • Corrections et améliorations de la détection des formats ICO, MP3 (moins de fausses alertes, recherche plus rapide), OGG (maintenant avec support de formats stream-audio et vidéos aléatoires)
  • Support des styles visuels de Windows XP
  • Intégration au systeme
  • Nouvelle version du format ESR pour les résultats de recherche (le fichier créé est beaucoup plus petit)
  • Styles variés d'affichage d'éléments dnas les fichiers trouvés
  • Glisser & déposer des éléments maintenant fonctionne comme si la touche SHIFT est pressée (auparavant cela échangeait les fichiers)
  • Corrections mineures et améliorations de l'explorateur de fichiers
  • Dans le formulaire d'enregistrement, la longueur du symbole variable a été réduite a 10 caractères (pour une meilleure compatibilité avec certaines banques et banques en ligne)
  • Les erreurs crituques sont notifiées dans le fichier into error.log
  • Corrections et améliorations dans le contrôle des fichiers de language
  • Autres corrections et améliorations générales

Extractor 2.22

  • Support du format playlist de Game Audio Player(format APL)
  • Corrections d'erreurs (le programme avait l'habitude de crasher quand nombre defichiers à rechercher étaient selectionnés - Erreur Windows, modification des boites de dialogues...)

Extractor 2.21

  • Correction d'erreurs (Cache optionnel, lecture des résultats de recherche, erreurs avec les skins Windows XP, ...)

Extractor 2.2

  • Support des groupes de fichiers DUN et REZ
  • Refonte complete de la detection des formats et des groupes de fichiers
  • possibilité d'utiliser différents moyens pour rechercher des fichiers:
    "C:\Documents\" - Tous les fichiers contenus dans la structure du dossier C:\Documents\ seront scannés
    "C:\Documents\*.dat" - Tous les fichiers *.dat contenus dans le dossier C:\Documents\ seront scannés
    "C:\Documents\file.dat" - Le fichier dans le dossier C:\Documents\file.dat sera scanné
  • il est maintenant possible d'ajouter des structures entieres de dossier à partir du disque dur vers la liste des fichiers trouvés (utile quand on veut créér des groupes de fichiers)
  • Corrections et améliorations du browser interne (affichage media, erreurs lors de l'affchage de fichiers images BMP , mode swich-over...)
  • Améliorations du support Web
  • Autres corrections mineures

Extractor 2.11

  • Corrections et améliorations du browser interne
  • Autres corrections mineures

Extractor 2.1

  • Support des formats 3DS, X
  • Correction et amélioration du décompte du groupe de fichiers VPP
  • Corrections d'erreurs mineures

Extractor 2.0

  • Localisation complete du programme
  • Support des formats EAMUS, HMP, SEC, STY, OGG
  • Support des groupes de fichiers ADAT, BAG, EIRES, GZP, HOG, LOD, MHW, PBO, RFF, RUS, SAD, VPP
  • Création des groupes de fichiers Half-Life wad (WAD) et Operation Flashpoint (PBO)
  • Corrections et améliorations de la détection des formats AIF, ASF, AU, HMI, IFF, MPG, VOC, WAV
  • Vitesse de recherche augmentée de 10% (par rapport à la version 1.8)
  • Si le nom de l'unité CD-R change pendant la sauvegarde des resultats de l recherche, alors lors du prochain chargement de ces résultats, les noms des unités CD-R seront affichés correctement
  • Classement des entrées selon divers criteres (titre, type, position, taille...)
  • Vous pouvez insérer divers fichiers a partir du disque dur et vers la liste des fichiers trouvés.
  • Amélioration de l'exploratuer de fichiers,affichage d'images et contenu multimedia directement dans le programme
  • Fond coloré des objets dans la liste des fichiers trouvés
  • Possibilité d'entrer des fichiers à rechercher par masque (ex.: "C:\Data\*.dat")
  • Fichier d'aide en HTML
  • Corrections d'ereurs et autres améliorations mineures

Extractor 1.8

  • Support des groupes de fichiers DNI, RES, STG
  • Correction et amélioration de la détection des formats ASF (format WMA déplacé sous ASF) et WAV
  • Corrections d'erreurs (Icones et formats, fonction ouvrir, corrections de textes, …)

Extractor 1.7

  • Support des groupes de fichiers PKR, POD, WDIR
  • Corrections et améliorations du support des formats MP3, MPG, SWF, WMA, WAV
  • Correction de la fonction "ouvrir"
  • Affichage des fichiers optionnels trouvés
  • Correction des programmes en lecture seule
  • Icones pour les types de fichiers
  • Autre corrections du programme et erreurs visuelles

Extractor 1.6

  • Support des formats DLS, FORM, PAL, RIFF, RMI, SGT
  • Support des groupes de fichiers DTA, PFF, WTN, ZWP
  • corrctions et améliorations de la detection des formats BIK, HMI, IT, MOD, MP3, MUS, XMI ainsi que pour tous les groupes de fichiers
  • Vitesse de recherche améliorée de 40%
  • Possibilité de créér des groupes de fichiers (fusion de fichiers, Quake pack, Aliens vs. Predator fastfile)
  • Support des fichiers de résultats en format CSV (chaînes séparées par une semi colonne)
  • Amélioration de la fonction taille automatique du cache (augmente la vitesse de la recherche comparée à une taille constante)
  • Correction de la positione de recherche initiale
  • Beaucoup de nouvelles options dans la page options
  • Autres corrections d'erreurs mineures

Extractor 1.5

  • Support des formats ASF, MNG, MP3, MPG, RA, RM, SMK, SWF, TGA
  • Support des groupes de fichiers CBF, DIR, FFL, FFS, GOB, HAL, LAB, VIV, PAK, XCR
  • Correction et amélioration de la détection des formats AIF, ANI, AUD, AVI, BIK, BMP, FLC, FLI, GIF, IFF, IT, LBM, JPG, MOD, MOV, MTM, PCX, PNG, S3M, VOC, VQA, WAV, XM, XMI
  • augmentaton remarquable de la vitesse de recherche, maintenant la vitesse de recherche dépend du nombre de formats recherchés
  • Conditions favorables pour l'enregistrement
  • Ajout de l'importation de fichier audio externe dans le fichier de recherche source
  • Enregistrement et chargement des résultats de recherche
  • Ajout et suppression d'objets dans les fichiers trouvés
  • Recherche globale dans la liste des fichiers trouvés
  • Information globale sur l'evolution du procesus de recherche
  • Correction de la fonction "ouvrir"
  • Description de la position et de la taille des fichiers trouvés sous forme hexadécimale
  • Estimation du temps de recherche (plusieurs formats)
  • Les fichiers trouvés sont nommés en accord avec le fichier source
  • téléchargements et sauvegarde de formats et groupes de fichiers renommés
  • Correction des noms des fichiers trouvés à l'aide du masque
  • Aide en format HLP
  • Autres corrections et améliorations mineures

Extractor 1.2

  • Possibilité de rechercher nombre de fichiers en une seule fois
  • Correction de la fonction "ouvrir"
  • selection des fichiers trouvés à l'aide de masques
  • Correction de la détection du format GIF
  • Historique des objets
  • Fenêtre de recherche redimensionnable

Extractor 1.1

  • Correction de la détection des formats MID et VOC
  • Corrections et améliorations du moteur de recherche et du systeme d'exploitation
  • Nouveau design, et bulles d'aide

Extractor 1.02

  • Corrections mineures

Extractor 1.01

  • Corrections mineures

Extractor 1.0

  • Support de 33 formats basiques
  • Premiere version officielle


Utilisation du programme

1) Tout d'abord selectionnez les fichiers dans lesquels vous souhaitez faire une recherche avec le bouton Selectionner , ou rentrez leur noms/chemins dans la case Fichiers à scanner . Quand plus d'un fichier est sélectionné, chaque fichier doit être séparé par un " au début et à la fin.

2) Ensuite choisissezle dossier dans lequel vous voulez extraire les fichiers trouvés avec le bouton Selectionner ou rentrez le chemin complet dans la case prévue à cet éffet (Sauvegarder les fichiers extraits vers:. ) si jamais ce dossier n'existe pas, le programme le crééra automatiquement.

3) Cochez les formats (voir page de formats) que vous voulez chercher dans la liste des formats choisis. Par la suite vous pourrez cocher les differents groupes de fichiers dans la liste Groupes de fichiers choisis (voir page des groupes de fichiers). Quand Extractor trouve une structure de groupe de fichiers lors de la recherche, il rechera les differents fichiers inclus dans ce groupe avec plus d'éfficacité.

4) Vous pouvez ajuster les options du programme et de recherche dans la page options.

5) pour commencer la recherche, cliquer sur le bouton Démarrer.

6) Pendant ou après que vous recherche est finie, vous pouvez ouvrir les fichiers trouvés (sous reserve que le fichier est associé aà un programme de visualisation) en utilisant le bouton Ouvrir ou en appuyant sur F5. Il est également possible d'utiliser d'autres fonctions du bouton Fonctions .

7) Vous pouvez extraire les fichiers trouvés. Cochez les cases pres des fichiers que vous voulez extraire en utilisant les bouttons +, -, Inv. les fichiers sélectionnés seront alors extraits vers le répertoire de destnation en utilisant le bouton Extraire.


Formats et groupes supportés

Formats et groupes de fichiers supportés

Formats

Type | Titre | Support | Occurence spécifique
3DS | 3D Studio File | 3D Studio |
AIF | AIFF Sound File | CoolEdit, GoldWave |
ANI | Windows Animate Cursor | Windows |
ASF | Advanced Streaming Format File | Windows Media Player, BSPlayer |
AU | AU Sound File | CoolEdit, GoldWave |
AUD | Westwood Audio File | Game Audio Player, Winamp | C&C, Dune 2000
AVI | Windows Video |  |
BIK | Bink Video | Outils video RAD |
BMP | Windows/OS2 Bitmap |  |
CUR | Windows Cursor | ACD See, Windows |
DDS | Direct Draw Surface | DirectX Texture Tool | jeux DirectX
DLS | Downloadable Sounds File | Awave Studio |
EAMUS | Electronic Arts Audio File | Game Audio Player | Need for Speed
FLC | Autodesk Animator File |  |
FLI | Autodesk Animator File |  |
FORM | Common format FORM |  |
GIF | Graphics Interchange Format |  |
HMI | Human Machine Interface Midi File | Winamp |
HMP | Human Machine Interface Midi File | Winamp |
ICO | Windows Icon | ACD See, PictView |
IFF | 8bit SVX Sound File | CoolEdit, GoldWave |
IT | ImpulseTracker Module | Impulse Tracker, Winamp |
JP2 | JPEG 2000 | IrfanView |
JPG | JPEG File Interchange Format |  |
LBM | Deluxe Paint Bitmap |  |
MID | Musical Instrument Digital Interface |  |
MNG | Animation Shop Animation | Animation Shop |
MOD | ProTracker, Fasttracker Module |  |
MP3 | MPEG Layer 3 |  |
MPG | Motion Picture Experts Group |  |
MOV | QuickTime Movie | QuickTime MoviePlayer |
MTM | MultiTracker Module | Winamp, Impulse Tracker |
MUS | Doom Midi File | Winamp | Doom
OGG | Vorbis File | GoldWave, Winamp |
PAL | Microsoft Palette | Paint Shop Pro |
PCX | Zsoft Painbrush Bitmap |  |
PDF | Adobe Acrobat Document | Adobe Acrobat |
PNG | Portable Network Graphics |  |
RA | RealAudio | RealPlayer |
RIFF | Common format RIFF |  |
RM | RealMovie | RealPlayer |
RMI | RIFF Midi File |  |
S3M | ScreamTracker Module | Scream Tracker, Winamp |
SCX | ColoRix Image File | PictView |
SEC | DirectMusic Segment | DML | Blood 2, Shogo
SGT | DirectMusic Segment Chunk | DML, DM-Player | Drakan, Blood 2, Shogo, NOLF
SMK | Smacker Video File | RAD Video Tools |
STY | DirectMusic Style | DML | Blood 2, Shogo
SWF | Shockwave Flash | Macromedia Flash, RealPlayer |
TGA | Truevision Targa Bitmap |  |
TIF | Tagged Image File Format |  |
TXT | Text File |  |
VOC | Creative Voice File | CoolEdit, GoldWave |
VQA | Westwood Movie File | MixViewer | C&C, Dune 2000
WAV | Windows Wave File |  |
X | DirectX File | DirectX |
XM | Extended Module | Fasttracker, Winamp |
XMI | Extended Midi File | Winamp | Jeux avec le systeme sonore Miles

Note

Quand le format est courant, son occurence ou programme supporté n'est pas mentionné.

Groupes de fichiers

Reading:

Type | Titre | Occurrence
007 | James Bond 007: Nightfire directory | James Bond 007: Nightfire
ADAT | Anachronox pack | Anachronox
APAK | Archangel pack | Archangel
AST | Highland Warriors groupfile | Highland Warriors
BAG | Emperor: Battle for Dune bag | Emperor: Battle for Dune
BCP | Warrior Kings pack | Warrior Kings
BIG | EA Big File | EA Sports NHL, Need For Speed: Porsche Unleashed, Need For Speed: Hot Pursuit 2, Command & Conquer Generals
BIN | Chasm pack | Chasm
CBF | Pterodon big file | Flying Heroes, Vietcong
DIR | Commandos directory | Commandos, Commandos: Beyond the Call of Duty
DRS | Age of Empires groupfile | Age of Empires, Age of Empires II
DNI | realMYST directory | realMYST
DTA | Hidden & Dangerous groupfile | Hidden & Dangerous
DUN | Frank Herbert's Dune pack | Frank Herbert's Dune
EIRES | Evil Islands pack | Evil Islands
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
FFS | Forge File System | Quadrax
GOB | LucasArts pack | Dark Forces, Jedi Knight
GRP | Duke Nukem 3D pack | Duke Nukem 3D, Shadow Warrior, Redneck Rampage
GZP | Giants pack | Giants
HAL | Mortyr groupfile | Mortyr
HOG | Descent 3 groupfile | Descent 3
IBF | Iron Storm Big File | Iron Storm
IRES | Innerloop Studios resource file | Project IGI, Project IGI2: Covert Strike
LAB | Outlaws groupfile | Outlaws
LDAT | Poselstvi trunu 2: Legenda pack | Poselstvi trunu 2: Legenda
LIB | Cultures groupfile | Cultures, Cultures 2
LOD | Heroes of Might and Magic 3 groupfile | Heroes of Might and Magic 3
MHW | Moorhuhn Winter-Edition groupfile | Moorhuhn Winter-Edition
MIX | Westwood groupfile | Command & Conquer, Command & Conquer: Renegade
MW4 | MechWarrior 4: Mercenaries groupfile | MechWarrior 4: Mercenaries
NPAK | Neocron pack | Neocron
PACK | Quake pack | Quake, Quake II, Half-Life, Kingpin, Soldier of Fortune, Daikatana
PAK | Robo Rumble pack | Robo Rumble
PBO | Operation Flashpoint groupfile | Operation Flashpoint
PFF | NovaLogic pack | Delta Force Land Warrior, Delta Force - Black Hawk Down
PKR | Tony Hawk's Pro Skater 2 pack | Tony Hawk's Pro Skater 2
POD | Nocturne pack | Nocturne, Blair Witch I, Blair Witch II
RES | Rage of Mages pack | Rage of Mages, Rage of Mages 2: Necromancer
REZ | LithTech Resource File | Blood2, Shogo, No One Lives Forever, No One Lives Forever 2, Aliens vs. Predator 2
RFA | Digital Illusions pack | Battlefield 1942, RalliSport Challenge
RFF | Blood pack | Blood
RUS | Sudden Strike groupfile | Sudden Strike
SPAK | Sin pack | Sin
SRSC | Drakan resource file | Drakan
SAD | Black & White groupfile | Black & White
SCM | ICQ Sound Scheme | ICQ
STG | Vampirjagd groupfile | Vampirjagd, Vampirjagd 2
TRWAD | Tomb Raider 3 wad | Tomb Raider 3
U | Unreal package | Unreal, Unreal 2, Unreal Tournament, Unreal Tournament 2003, DeusEx, Rune, The Wheel Of Time, Klingon Honor Guard, Deep Space Nine, Undying, X Com Enforcer, Nerf Arena Blast
VDF | Gothic groupfile | Gothic
VPP | Volition groupfile | Summoner, Red Faction
WAD | Doom/Half-Life wad | Doom, Doom II, Half-Life
WDIR | Worms pack | Worms 2, Worms Armageddon
WTN | Witan Entertainment groupfile | Moorhuhn 2
XCR | Warlords Battlecry groupfile | Warlords Battlecry
ZWP | Dark Reign 2 pack | Dark Reign 2

Creating:

Type | Titre | Format
*.* | Fusion des fichiers |
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
GRP | Duke Nukem 3D pack | Duke Nukem 3D
PACK | Quake pack | Quake
PBO | Operation Flashpoint groupfile | Operation Flashpoint
RAR | RAR archive | RAR 2.0
WAD | Half-Life wad | Half-Life
ZIP | ZIP archive | ZIP 1.0

Si vous rencontrez un format ou un groupe de fichiers non supporté par Extractor, veuillez s'il vous plait en informer l'auteur d'Extractor en fournissant son titre, sa description ou adresse URL.

Veuillez trouver plus d'information et un guide d'utilisation d'Extractor dans la rubrique Astuces.

Liens

ACD See
Animation Shop
Awave Studio
BSPlayer (1), (2)
CoolEdit
Deus ex Machina
DML
DM-Player
Game Audio Player (1), (2)
GoldWave
Impulse Tracker
MixViewer
Paint Shop Pro
PictView
QuickTime MoviePlayer
RAD Video Tools
RealPlayer
Winamp
Windows
Windows Media Player

Note

Certains formats necessitent des Plug Ins. ceux-ci ne sont pas inclus dans l'installation d'Extractor, mais il est possible de les télécharger séparement sur un site Web consacré au programme en question.


Raccourcis clavier

F1 | help
Fenêtre principale:
F2 | Choisir le dossier où sauvegarder les fichiers
F3 | Choisir les fichiers à rechercher
F5 | Commencer la recherche dans les fichiers choisis
Alt+X | Sortie du programme
Fenêtre de recherche:
Alt+X | Terminer la recherche, fermer la fenêtre
F3 | Montrer fichier
F5 | Extraire les fichiers marqués
F7 | Chercher le texte
Shift+F7 | Nouvelle recherche de texte
Ctrl+T | Format de temps
Ctrl+I | Importer des fichiers
Ctrl+G | Créér un groupe de fichiers
Ins | Inserer un nouvel objet
Ctrl+Ins | Inserer des fichiers du disque dur dans la liste
Del | Effacer les éléments choisis
F6 | Renommer/remplacer les éléments choisis
Ctrl+R | Rapport de recherche
Ctrl+S | Sauvegarder les résultats de la recherche
Liste de fichiers trouvés:
Alt+Enter | Propriétés du fichier
Enter | Ouvrir fichier
Ctrl+A | Choisir tous les fichiers
Ctrl+N | Annuler la sélection de tous les fichiers
Vue du fichier:
Esc | Fermer fenêtre
1,2,3,4 | Basculer en mode vue de fichier
C | Basculer en vue de symbole 0-31
F | Ajuster l'image à la fenêtre
B | Filtre image bilinéaire


Terminologie

Terminologie (dans Extractor)

Choisir - Cocher la case près du nom de l'objet
Selection - Selection
Pointer - Selectionner en utilisant la ligne soulignant l'objet
Extraire - Copier une partie du fichier original dans un nouveau fichier indépendant
Groupe de fichiers - Fichier contenant d'autre fichiers (similaire à une archive, mais généralement sans compression)


Erreurs

Dans le cas ou une erreur est découverte, veuillez s'il vous plait en informer l'auteur.

La description des erreurs doit contenir les informations suivantes:

  • Le nom de code de la version du programme, en entier si possible (ex.: 1.5.6.436 ou 1.5 Beta 4)
  • Une description détaillée de la situation lors de la quelle l'erreur s'est produite (ex.: L'erreur s'est produite lors de la recherche d'un fichier .dat (faisant partie du programme x), quand le format MPG a été testé, aucun écran d'erreur n'est apparu. Le programme n'a plus répondu, et a du être fermé à l'aide du gestionnaire des tâches. L'erreur s'est répétée lors de la recherche suivante.)
  • Le systeme d'exploitation et la configuration matérielle de votre ordinateur.
  • la liste des programmes en cours d'exécution lorsque l'erreur est apparue.

Note

Parfois le programme n'établit pas la taille du fichier trouvé de façon correcte. Ce n'est pas necessairement la faute d'Extractor. cela peut être la faute du programme qui a créé le fichier trouvé. Nous avons trouvé un certain nombre de fichiers ayant une erreur de données. Si un tel fichier est trouvé et si vous essayez de l'ouvrir ou de l'extraire, le programme notifiera vraisemblablement une erreur lors de sa lecture. Cela peut être causé par une erreur du media sur lequel le fichier est stocké ou bien par une taille incorrecte du fichier de destination. Dans ce cas, essayez de changer la taille du fichier dans le menu fichier/Particularités/propriétés.


Astuces

Comment obtenir une vitesse de recherche plus élevée?

  • Plus le nombre de formats recherchés est faible, plus la vitesse de recherche est grande . Ceci s'explique par les niveaux variables de demande lors de la reconnaissance de fichiers, qui affecte d'autant plus la vitesse de recherche. Plus la détection est compliquée, plus la recherche est longue. Cela affecte nottamment les formats stream (la plupart du temps MP3), où il est quelques fois très difficile d'identifier si le fichier trouvé est effectivement le fichier cherché, ou bien une simple coïncidence du fait d'une combinaison de données qui ressemble à celle du fichier recherché, mais qui n'a rien à voir au final. C'est pour cette raison qu'il est nécessaire de bien choisir avec considération les formats à rechercher.
  • Le nombre de groupes de fichiers choisis ne prolonge pas la recherche, en aucune façon. Au contraire, vous pouvez visiblement accélérer la recherche et obtenir les vrais fichiers que vous recherchez si ils sont contenus dans un groupe de fichiers.
  • Vous pouvez également accélérer la vitese de recherche en acceptant la taille automatique de la mémoire cache. Le programme contient une optimisation pour un changement de taille de cache dynamique qui accélere la vitesse de recherche.
  • Vous atteindrez une vitesse de recherche considérablement plus haute en utilisant des systemes d'exploitation NT, ex. Windows NT, Windows 2000 and Windows XP.

Formats de fichiers considérés comme groupes de fichiers

  • Certains formats (comme PDF ou SWF) peuvent agir de la même maniere qu'un groupe de fichier, car ils peuvent contenir différents formats (JPG, MP3...). Souvenez-vous que si tous les formats de fichiers sont sélctionnés en recherche, ceux placés en début de liste auront une plus grande priorité (fichiers PDF et SWF dans ce cas) et les formats contenus dans ces fichiers ne seront pas trouvés (seront omis). Vous pouvez changer cela en décochant la case Scan rapide dans le menu "Options/préférences". Tous les formats seront alors trouvés, incluant ceux contenus dans les fichiers PDF et SWF. Par contre, ceci se fera au détriment de la vitese de recherche, qui sera réduite.

Ouvrir les fichiers

  • Lors de l'ouverture d'un fichier pas Extractor, il est possible que le fichier trouvé ne s'ouvre pas correctement alors qu'il n'y a aucun probleme pour l'ouvrir manuellement avec le programme qui supporte ce format. Dans ce cas, un mauvaise association de type de fichier doit être à l'origine du problème. Les associations de fichiers doivent être enregistrées dans la section du registre HKEY_CLASSES_ROOT\...\shell\open\command comme suivant ”[nom du fichier]” ”%1”. Si vous n'utilisez pas de marques de quotations avec les paramètres %1 , le fichier avec un espace dans son titre sera ouvert (ex: Son 00001.wav), et la premiere partie du nom du fichier(devant l'espace) devient paramètre (dans ce cas, Son).

Contrôle de mise à jour d'une nouvelle version

  • Dans le cas où vous utilisez une connection internet par ligne téléphonique et que vous avez la fonction "verifier si Nouvelle version disponible" activée et que vous utilisez Internet Explorer, vous pouvez être invité à vous connecter à Internet si vous n'êtes pas en ligne (une boite de dialogue "Connecter" apparaît). Pour ne plus avoir cette boite de dialogue, dans Internet Explorer allez dans Outils/Options Internet .../Connections/options de numérotation et choisissez l'option ne jamais établir de connexion.

Fichier de configuration Extractor.ini

  • Le fichier de configuration Extractor.ini est créé dans les dossiers suivants dans l'ordre (si le premier n'est pas accessible, Extractor utilise le suivant et ainsi de suite):
    1. dans le dossier Programmes
    2. Dnas le dossier où se trouve Extractor
    3. dans le dossier Windows
    4. A la racine de C
    5. Le fichier ne sera pas créé


Copyright

Programme Extractor. Tous droits réservés par son auteur, eu-égard à la loi no. 121/2000. L'auteur a seul le droit d'en autoriser son utilisation et sa copie.
A présent, ce programme est distribué sous forme de shareware bien qu'il soit possible de le distribuer gratuitement. La version Shareware (non-enregistrée) contient, par rapport à la version enregistrée, certaines restrictions. Si vous désirez obtenir la version sans limitations, il est necessaire de vous enregistrer.
Apres votre enregistrement (qui vous permet d'obtenir vos textes et codes d'enregistrement), le programme devient version enregistrée, et sa copie en est strictement interdite.La duplication des codes et texte d'enregistrement est interdite. Les codes et texte d'enregistrement ne peuvent être utilisés que par l'utilisateur, société ou organisation enregistrée. Il est également interdit d'accéder à la structure du programme, de le décompiler ou de faire des changements au sein de celui-ci.
L'enregistrement individuel n'est valide que pour un utilisateur et un ordinateur. les enregistrements multiples utilisés par les sociétés ou organisations sont valables pour un nombre illimité d'ordinateurs ou d'utilisateurs. Tous les détails utiles concernant l'enregistrement du programme Extractor se trouvent dans la section enregistrement .


Limitations de la version shareware

  • 30 fichiers maximum en résultat de recherche
  • Vous ne pouvez pas commencer la recherche par position et changer rapidement de position à l'aide du curseur de la souris


Enregistrement

Enregistrement: France

Qu'obtient-on en s'enregistrant?
  • Le programme au complet, avec toutes avec toutes ses options activées
  • Toutes les mises à jour du programme sont gratuites
  • Support technique ainsi que l'annonce de mises a jour du programme

Vous pouvez enregistrer Extractor par:

Transfert depuis votre banque:
Dans votre banque, demandez un formulaire de transfert de crédit vers l'étranger. Changez la monnaie en CZK (Couronne tchèque) , en accord avec le taux actuel de change, et dont le montant est égal au prix demandé pour enregistrer le programme Extractor. Le numero de compte vers lequel éffectuer le transfert est le 8002490257/0100 dans la Komercni banka, Ceska republika (Banque Commerciale, république Tchèque), nom du compte Vaclav Novacek. Veullez vous referer au formulaire d'inscription dans la rubrique "A propos/Enregistrement" dans Extractor.
Au moment de l'envoi du Règlement, veuillez joindre le formulaire d'enregistrement. Vous recevrez alors un texte d'enregistrement ainsi qu'un code, que vous devrez entrer dans le menu "A propos/enregistrement" de Extractor.

Si vous n'avez toujours pas reçu un email contenant les informations d'enregistrement au bout d'un mois, veuillez contacter l'auteur.

Attention: Extractor ne vous est pas envoyé par email avec les informations d'enregistrement, mais est disponible sur internet.

Le prix de l'enregistrement pour un utilisateur est de 200 CZK (Couronne tchèque), les eregitrements multiples pour les sociétes ou organisations sont de 1000 CZK.


Mises à jour

Comme n'importe quel autre programme, Extractor n'est pas parfait et contient des erreurs. nous utilisons des mises à jour afin de corriger ces petites erreurs et pour enrichir le programme avec de nouvelles fonctions. Ces mises à jour sont fonctionnnelles sans restrictions pour l'utilisateur enregistré donc il n'est aucunement question de payer encore pour la même chose. Si vous désirez enregistrer cette version, toutes les versions futures seront gratuites pour vous. Comme vous pouvez le constater, l'enregistrement d'extractor est avantageux pour vous.


Auteur

Nova Software
Vaclav Novacek
Bolesiny 55
33901 Klatovy
Tchčque république

Web: http://www.volny.cz/nova-software
Email: nova-software@volny.cz