Extractor

Extractor 2.4
© 1994-2003 Nova Software


What is Extractor?

Extractor is a program that enables a search for any type of formats in selected files. The size of files found is calculated according their contents and are identical with the original file size. It is very easy to save and then later find the results of your search without having to search through files again. Extractor contains a lot of other useful functions for work with files. They can be used to extract, divide, merge or import files or create groupfiles of various formats. The files already found is possible to open and view without extracting them. One of the functions also enables you to search for an arbitrary text in found file items or sort items according to given criteria.


Whats new?

Extractor 2.4

  • format DDS support
  • groupfile 007, APAK, IBF, IRES, MW4 support
  • creation of groupfile BIG
  • detection of information about formats AVI, OGG, WAV improvements
  • improvement of MOV, S3M, SWF, TXT (added config) formats detection
  • improvement of detection and loading of BIG groupfiles (originaly VIV), CBF, RFA
  • complete English and French localization
  • code optimalization
  • new multimedia player (imported MediaPlayer)
  • added possibility of file imported as a reference to a file on disk (source file data do not change, only name, position and size of the source file of the file found will be changed), usefull when creating groupfiles
  • dragging files into the main window while holding Ctrl and Shift keys adds these files to list
  • other corrections and improvements (groupfiles detection, report, ...)

Extractor 2.34

  • format PDF support
  • groupfile AST support
  • formats ICO, MPG, TGA detection support
  • added possibility to change the position of the current file search using mouse pointer in progress bar
  • full support for Windows XP visual styles
  • other small corrections and improvements

Extractor 2.33

  • format TIF support
  • groupfiles LDAT, RFA, SRSC support
  • corrections in groupfile U counting (new version UT2003 problems)
  • formats control improvements

Extractor 2.32

  • groupfiles DRS, LIB, NPAK, TRWAD, U support (and related to UNR, UMX, UAX, UTX, ...)
  • creation of groupfiles RAR and ZIP

Extractor 2.3

  • check of input format and groupfile plug-ins and output groupfile plug-ins
  • formats JP2, TXT support and groupfiles BCP, MIX support (format C&C Renegade), SCM, VDF
  • groupfile GRP creation
  • groupfile PBO counting improvements
  • new version of API 1.1, some structures and functions changed, plug-ins support for groupfiles creation added
  • complete Slovak localization (program and help file)
  • format search optimalization
  • fully dynamic format control, search speed adjusted depending on number of formats searched for (the less formats you search for, the more evident the increase in search speed is)
  • corrections and improvement of ICO, MP3 formats detection (less false allerts - faster search), OGG (now supports random stream formats - audio, video)
  • Windows XP visual styles support
  • system integration
  • new version of ESR format for search results storage (resulting file is a few times smaller)
  • various styles of item display in files found
  • drag & drop operation with items works now as a shift (worked as an exchange before)
  • small file browser corrections and improvements
  • in registration form the lenght of the variable symbol shortened to 10 characters (for better compatibility with some banks, internet and mobile banking)
  • notation of critical errors into error.log file
  • corrections and improvements in language file control
  • other general corrections and improvements

Extractor 2.22

  • playlist (format APL) in Game Audio Player (GAP) program support
  • errors correction (program used to crash when number of files for search was selected - Windows's error, change of dialogs,...)

Extractor 2.21

  • errors correction (optional cache, search results reading, errors related to skins in Windows XP, ...)

Extractor 2.2

  • groupfiles DUN, REZ support
  • complete renewal of formats and groupfiles detection, entry and administration
  • possibility of various ways for file search:
    "C:\Documents\" - all the files contained in the C:\Documents\ folder structure will be searched through
    "C:\Documents\*.dat" - all the files *.dat type of files contained in the C:\Documents\ folder will be searched through
    "C:\Documents\file.dat" - file in the C:\Documents\file.dat will be searched through
  • it is now possible to add the whole folder structures from disk to the list of found files (useful when creating groupfiles)
  • corrections and improvements of internal browser (media displaying, errors while displaying BMP images, mode swich-over...)
  • Internet support improvements
  • other minor corrections

Extractor 2.11

  • corrections and improvements of internal browser
  • other minor corrections

Extractor 2.1

  • 3DS, X formats support
  • VPP groupfile counting improvement and correction
  • minor errors corrections

Extractor 2.0

  • complete program localization
  • formats EAMUS, HMP, SEC, STY, OGG support
  • groupfiles ADAT, BAG, EIRES, GZP, HOG, LOD, MHW, PBO, RFF, RUS, SAD, VPP support
  • groupfiles Half-Life wad (WAD) and Operation Flashpoint groupfile (PBO) creation
  • corrections and improvement of AIF, ASF, AU, HMI, IFF, MPG, VOC, WAV formats detection
  • 10% rise of search speed (compared to 1.8 version)
  • variable labeling of CD-R unit during search results saving, when search results are downloaded unit name is updated accordingly
  • entry assortment according to given criteria (title, type, pozition, sise, note in ascending or descending sequence)
  • you can insert various files from disk into list of found files
  • file browser improvement,view graphic and multimedia files right in the program
  • coloured item background in found files
  • enter searched files by file mask (e.g.: "C:\Data\*.dat")
  • HTML help file
  • errors correction and other minor improvements

Extractor 1.8

  • groupfiles DNI, RES, STG support
  • correction and improvement of ASF formats detection (format WMA moved undrer ASF), WAV
  • error corrections (icon and formats administrations, Open function, texts corrections, …)

Extractor 1.7

  • groupfiles PKR, POD, WDIR support
  • correction and improvement of MP3, MPG, SWF, WMA, WAV formats support
  • Open function correction
  • optional found file display
  • programs read-only mode correction
  • type of file icons
  • other corrections of program and visual errors

Extractor 1.6

  • formats DLS, FORM, PAL, RIFF, RMI, SGT support
  • groupfiles DTA, PFF, WTN, ZWP support
  • correction and improvement of BIK, HMI, IT, MOD, MP3, MUS, XMI formats detection and of all froupfiles
  • 40% rise of search speed
  • possibility to create groupfiles (merging files, Quake pack, Aliens vs. Predator fastfile)
  • support of search results in CSV format (chains separated by semicolon)
  • automatic cache size improvement (speeds up search compared to constant size)
  • initial search position correction
  • many new options on Options page
  • other minor errors correction

Extractor 1.5

  • formats ASF, MNG, MP3, MPG, RA, RM, SMK, SWF, TGA support
  • groupfiles CBF, DIR, FFL, FFS, GOB, HAL, LAB, VIV, PAK, XCR support
  • correction and improvement of AIF, ANI, AUD, AVI, BIK, BMP, FLC, FLI, GIF, IFF, IT, LBM, JPG, MOD, MOV, MTM, PCX, PNG, S3M, VOC, VQA, WAV, XM, XMI formats detection
  • remarkable search speedingv, speed now depends on number of searched formats
  • favourable registration conditions
  • import of external file into searched (source) file
  • downloading and saving search results
  • adding and deleting of found files items
  • global search in list of found files
  • overall information about search process - Report
  • correction of Open function
  • depiction of found files position and size in hexadecimal form
  • estimation of finish search time (many formats)
  • found files are named according to source file
  • downloading and saving formats and groupfiles labelling
  • correction of found files labelling with use of mask
  • help file in HLP format
  • other minor corrections and improvements

Extractor 1.2

  • possibility to search number of files at once
  • correction of Open function
  • found files selection using mask
  • correction of GIF format detection
  • items history
  • sizable search window size

Extractor 1.1

  • correction of MID and VOC formats detection
  • corrections and improvements of search engine and operating system
  • new design and informative strands

Extractor 1.02

  • minor corrections

Extractor 1.01

  • minor corrections

Extractor 1.0

  • 33 basic formats support
  • first official version


Program use procedure

1) Firstly select files you want to search using Select button or type their titles in Files to scan field. When selecting more than one file, each file title has to be devided by " symbol on both sides.

2) Then select folder where you want files to be stored using Select button or type the files title in Save extracted files to:. In case this folder does not exist, program will create it automaticaly.

3) Check file formats (see Formats page) you wish to search for in Selected formats list. Next you can check groupfiles in Selected groupfiles list (see Groupfiles page). When Extractor finds a permited groupfile structure, it will seach for files in a different, much faster way.

4) You can adjust program and search features on options page.

5) To start search click Start button.

6) During or after your search is finished you can run the searched files (using program associated with appropriate bak) using Open button or wiev it using F5 key. It is also possible to use some of the other functions of Functions button.

7) You can extract found files. Check the checking field next to files you want to extract using +, -, Inv keys. Checked files then extract into selected folder using Extract button.


Supported formates and groupfiles

Formats

Type | Title | Support | Specific occurrence
3DS | 3D Studio File | 3D Studio |
AIF | AIFF Sound File | CoolEdit, GoldWave |
ANI | Windows Animate Cursor | Windows |
ASF | Advanced Streaming Format File | Windows Media Player, BSPlayer |
AU | AU Sound File | CoolEdit, GoldWave |
AUD | Westwood Audio File | Game Audio Player, Winamp | C&C, Dune 2000
AVI | Windows Video |  |
BIK | Bink Video | RAD Video Tools |
BMP | Windows/OS2 Bitmap |  |
CUR | Windows Cursor | ACD See, Windows |
DDS | Direct Draw Surface | DirectX Texture Tool | DirectX games
DLS | Downloadable Sounds File | Awave Studio |
EAMUS | Electronic Arts Audio File | Game Audio Player | Need for Speed
FLC | Autodesk Animator File |  |
FLI | Autodesk Animator File |  |
FORM | Common format FORM |  |
GIF | Graphics Interchange Format |  |
HMI | Human Machine Interface Midi File | Winamp |
HMP | Human Machine Interface Midi File | Winamp |
ICO | Windows Icon | ACD See, PictView |
IFF | 8bit SVX Sound File | CoolEdit, GoldWave |
IT | ImpulseTracker Module | Impulse Tracker, Winamp |
JP2 | JPEG 2000 | IrfanView |
JPG | JPEG File Interchange Format |  |
LBM | Deluxe Paint Bitmap |  |
MID | Musical Instrument Digital Interface |  |
MNG | Animation Shop Animation | Animation Shop |
MOD | ProTracker, Fasttracker Module |  |
MP3 | MPEG Layer 3 |  |
MPG | Motion Picture Experts Group |  |
MOV | QuickTime Movie | QuickTime MoviePlayer |
MTM | MultiTracker Module | Winamp, Impulse Tracker |
MUS | Doom Midi File | Winamp | Doom
OGG | Vorbis File | GoldWave, Winamp |
PAL | Microsoft Palette | Paint Shop Pro |
PCX | Zsoft Painbrush Bitmap |  |
PDF | Adobe Acrobat Document | Adobe Acrobat |
PNG | Portable Network Graphics |  |
RA | RealAudio | RealPlayer |
RIFF | Common format RIFF |  |
RM | RealMovie | RealPlayer |
RMI | RIFF Midi File |  |
S3M | ScreamTracker Module | Scream Tracker, Winamp |
SCX | ColoRix Image File | PictView |
SEC | DirectMusic Segment | DML | Blood 2, Shogo
SGT | DirectMusic Segment Chunk | DML, DM-Player | Drakan, Blood 2, Shogo, NOLF
SMK | Smacker Video File | RAD Video Tools |
STY | DirectMusic Style | DML | Blood 2, Shogo
SWF | Shockwave Flash | Macromedia Flash, RealPlayer |
TGA | Truevision Targa Bitmap |  |
TIF | Tagged Image File Format |  |
TXT | Text File |  |
VOC | Creative Voice File | CoolEdit, GoldWave |
VQA | Westwood Movie File | MixViewer | C&C, Dune 2000
WAV | Windows Wave File |  |
X | DirectX File | DirectX |
XM | Extended Module | Fasttracker, Winamp |
XMI | Extended Midi File | Winamp | games with Miles Sound Systemem

Note

Where format is common its occurrence or support program is not mentioned.

Groupfiles

Reading:

Type | Title | Occurrence
007 | James Bond 007: Nightfire directory | James Bond 007: Nightfire
ADAT | Anachronox pack | Anachronox
APAK | Archangel pack | Archangel
AST | Highland Warriors groupfile | Highland Warriors
BAG | Emperor: Battle for Dune bag | Emperor: Battle for Dune
BCP | Warrior Kings pack | Warrior Kings
BIG | EA Big File | EA Sports NHL, Need For Speed: Porsche Unleashed, Need For Speed: Hot Pursuit 2, Command & Conquer Generals
BIN | Chasm pack | Chasm
CBF | Pterodon big file | Flying Heroes, Vietcong
DIR | Commandos directory | Commandos, Commandos: Beyond the Call of Duty
DRS | Age of Empires groupfile | Age of Empires, Age of Empires II
DNI | realMYST directory | realMYST
DTA | Hidden & Dangerous groupfile | Hidden & Dangerous
DUN | Frank Herbert's Dune pack | Frank Herbert's Dune
EIRES | Evil Islands pack | Evil Islands
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
FFS | Forge File System | Quadrax
GOB | LucasArts pack | Dark Forces, Jedi Knight
GRP | Duke Nukem 3D pack | Duke Nukem 3D, Shadow Warrior, Redneck Rampage
GZP | Giants pack | Giants
HAL | Mortyr groupfile | Mortyr
HOG | Descent 3 groupfile | Descent 3
IBF | Iron Storm Big File | Iron Storm
IRES | Innerloop Studios resource file | Project IGI, Project IGI2: Covert Strike
LAB | Outlaws groupfile | Outlaws
LDAT | Poselstvi trunu 2: Legenda pack | Poselstvi trunu 2: Legenda
LIB | Cultures groupfile | Cultures, Cultures 2
LOD | Heroes of Might and Magic 3 groupfile | Heroes of Might and Magic 3
MHW | Moorhuhn Winter-Edition groupfile | Moorhuhn Winter-Edition
MIX | Westwood groupfile | Command & Conquer, Command & Conquer: Renegade
MW4 | MechWarrior 4: Mercenaries groupfile | MechWarrior 4: Mercenaries
NPAK | Neocron pack | Neocron
PACK | Quake pack | Quake, Quake II, Half-Life, Kingpin, Soldier of Fortune, Daikatana
PAK | Robo Rumble pack | Robo Rumble
PBO | Operation Flashpoint groupfile | Operation Flashpoint
PFF | NovaLogic pack | Delta Force Land Warrior, Delta Force - Black Hawk Down
PKR | Tony Hawk's Pro Skater 2 pack | Tony Hawk's Pro Skater 2
POD | Nocturne pack | Nocturne, Blair Witch I, Blair Witch II
RES | Rage of Mages pack | Rage of Mages, Rage of Mages 2: Necromancer
REZ | LithTech Resource File | Blood2, Shogo, No One Lives Forever, No One Lives Forever 2, Aliens vs. Predator 2
RFA | Digital Illusions pack | Battlefield 1942, RalliSport Challenge
RFF | Blood pack | Blood
RUS | Sudden Strike groupfile | Sudden Strike
SPAK | Sin pack | Sin
SRSC | Drakan resource file | Drakan
SAD | Black & White groupfile | Black & White
SCM | ICQ Sound Scheme | ICQ
STG | Vampirjagd groupfile | Vampirjagd, Vampirjagd 2
TRWAD | Tomb Raider 3 wad | Tomb Raider 3
U | Unreal package | Unreal, Unreal 2, Unreal Tournament, Unreal Tournament 2003, DeusEx, Rune, The Wheel Of Time, Klingon Honor Guard, Deep Space Nine, Undying, X Com Enforcer, Nerf Arena Blast
VDF | Gothic groupfile | Gothic
VPP | Volition groupfile | Summoner, Red Faction
WAD | Doom/Half-Life wad | Doom, Doom II, Half-Life
WDIR | Worms pack | Worms 2, Worms Armageddon
WTN | Witan Entertainment groupfile | Moorhuhn 2
XCR | Warlords Battlecry groupfile | Warlords Battlecry
ZWP | Dark Reign 2 pack | Dark Reign 2

Creating:

Type | Title | Format
*.* | Merging files |
FFL | Aliens vs. Predator fastfile | Aliens vs. Predator
GRP | Duke Nukem 3D pack | Duke Nukem 3D
PACK | Quake pack | Quake
PBO | Operation Flashpoint groupfile | Operation Flashpoint
RAR | RAR archive | RAR 2.0
WAD | Half-Life wad | Half-Life
ZIP | ZIP archive | ZIP 1.0

If you happen to come accross a format or a groupfile not supported by Extractor program, please inform the Extractor author by sending its title, description or URL address.

Read more of other useful information and how to use Extractor effectively in Tips section.

Links

ACD See
Animation Shop
Awave Studio
BSPlayer (1), (2)
CoolEdit
Deus ex Machina
DML
DM-Player
Game Audio Player (1), (2)
GoldWave
Impulse Tracker
MixViewer
Paint Shop Pro
PictView
QuickTime MoviePlayer
RAD Video Tools
RealPlayer
Winamp
Windows
Windows Media Player

Note

Some formats need plugins. Those are not a part of the installation but it is possible to download them separately from a web side relevant to the program.


Keyboard shortcuts

F1 | help
Main window:
F2 | select folder in which to save files
F3 | select files for search
F5 | start search through selected files
Alt+X | exit program
Search window:
Alt+X | end search, close window
F3 | show file
F5 | extract marked files
F7 | search for text
Shift+F7 | new search for text
Ctrl+T | time format
Ctrl+I | import files
Ctrl+G | create groupfile
Ins | insert new item
Ctrl+Ins | insert files from disk into list
Del | delete selected items
F6 | rename/replace selected items
Ctrl+R | search reports
Ctrl+S | save search results
List of found files:
Alt+Enter | file properties
Enter | open file
Ctrl+A | select all files
Ctrl+N | cancel selection of all files
File view:
Esc | close window
1,2,3,4 | switch file view mode
C | switch symbol view 0-31
F | fill window with picture
B | bilinear picture filter


Terminology

Terminology (in Extractor)

Checking - tick the field next to the item title
Selection - inverse item depiction
Focus - selection using dotted line surrounding the item
Extraction - copying a part of original file into a new independent file
Groupfile - file containing other files (similar to archive usualy without compresion)


Errors

In case an error is found, please inform the author.

The description of the error should contain following specifications:

  • number code of the program version, in full if possible (e.g.: 1.5.6.436 or 1.5 Beta 4)
  • detailed description of the situation, when the error occured (e.g.: The error has occured during the search of file.dat file (part of X program), while the MPG format was tested. No error window appeared. There was no response from the program, it had to be terminated by the help of Task manager. The error was repeated in the next search)
  • operating system version and hardware configuration of your computer
  • list of programs running while the error occured

Note

Sometimes the program does not establish the lenght of the found file correctly. It is not necessarily Extractors fault. It can be a fault of the program that created the found file. We found a number of files containing error data. If such file is found and you are trying to open it or extract it, program will probably notify of error while reading this file. It can be caused by a media error on which the file is stored or by wrong file lenght designation. In this case you can try to correct the error manually by changing the file size in file features/properties.


Tips

How to reach higher search speed?

  • The smaller number of formats you search the higher search speed you can reach. That is because formats have various level of demand factor for recognition which also influences the search speed. The most complicated detection and longest search time usualy affects stream formats (mostly MP3s) where it is sometimes very difficult to identify wheather we have the file we searched for or accidentaly favourable data combination. For this rason it is necessary to consider carefully which formats you will be searching for.
  • Groupfiles acceptance does not prolong search time in any way. On the contrary, you can markedly speed up the search and get the true file titles that the searched groupfile contains.
  • You can also accelerate search speed by accepting automatic size of cache memory. Program contains optimalization for dynamic change of cache size that accelerates the search speed.
  • You will reach considerably higher search speed using NT operating systems, e.g. Windows NT, Windows 2000 and Windows XP.

File formats as groupfiles

  • Some file formats (like PDF or SWF) can act in a similar way as groupfiles and contain other files of various formats (JPG, MP3...). Remember when all those formats are selected for search, those files found at first will get priority (they are host files PDF and SWF in this case) and formats contained within these files will not be found (will be omited). You can change this by deselecting Fast scanning button (Options/Preferences). Then all formats will be found, including those contained within PDF and SWF files. The disadvantage of this option is deceleration of search speed.

Opening files

  • While opening files from Extractor it is possible that found file will not open even though there is no problem opening it manualy in the program that supports its format. In this case, wrong association of file type and certain program can be the problem. The associations should be registered in section HKEY_CLASSES_ROOT\...\shell\open\command as follows: ”[filename]” ”%1”. If you do not use quotation marks with parameter %1 symbol, the file with a space in its title will be opened (e.g.: Sound 00001.wav), then the first part of the filename (up to a space) becomes parameter (in this case Sound).

New program version control

  • If case you are using telephone line internet connection, you have "Find new version access" function on and use Internet Explorer, you may be prompted to connect to the Internet while in Offline mode (dialog window "Connect" appears). To get a rid of this, in Internet Explorer program go to Tools/Internet options.../Connections/Dialup options and choose the option Never dial a connection.

Configuration file Extractor.ini

  • Configuration file Extractor.ini is created in folders in following order (if it's not possible, Extractor uses other option):
    1. in program folder
    2. in current folder
    3. in Windows folder
    4. in root disk C folder
    5. file will not be created


Copyright

The Extractor program. All rights are reserved by its author, according to the law no. 121/2000 and it is the authors right to authorise its use and copying.
At the present the program is distributed as shareware therefore it is possible to distribute it freely. Shareware (non-registered) version contains, in contrast to registered version, certain restrictions. If you wish to get the authorised version with no restrictions it is necessary to register.
After your registration (providing register text and code) the program becomes the registered version, its further copying is strictly prohibited. Duplication of the register text and code is prohibited. The register text and code can only be used by the registered user, firm or organization. It is also prohibited to get in the program structure, decompile it or make changes to it.
The single-user registration is only valid for one user and one computer. Multiregistration used by firms and organizations is valid for un-limited number of users and computers. All usefull details about the Extractor program registration can be found in Registration section.


Restrictions of the shareware version

  • maximum 30 files found
  • you cannot use start search position and quick change of actual position by mouse cursor


Registrace

Registration

Registration for other places (outside Czech Republic)

What do you get for registering?
  • Full program, with all features enabled
  • All updates and new versions of the program for free
  • Technical support and updates about new versions of the program

You can register Extractor by:

Bank transfer:
At your bank branch ask for a form for credit transfers to outland. Change your currency to CZK (Czech crown) according to the actual exchange rate so amount is equal with related registration charge. The account number to transfer to is 8002490257/0100 in Komercni banka, Ceska republika (Commercial bank, Czech Republic), account name Vaclav Novacek. Memo field is number from the About/Registration form in Extractor.
At the same time with amount pay send filled registration form. You will then receive a registration text and code, which you enter into Extractor in the About/Registration window.

If you do not receive an email with registration information within one month, send email about the registration.

Warning: Extractor is not mailed to you with registration information, but rather is available on the Internet.

Price of one user registration is 200 CZK (Czech crown), multiregistration for firms and organizations 1000 CZK.

Other important informations you found in section Copyright.


Updates

Just like any other program the Extractor is not perfect and can contain errors. We use updates to dispatch these little errors and to enrich programs with new functions. These updates are functional without any restrictions for registered user so he doesn't need to pay again for the same thing. If you like to register the current version, all your future versions will be free for you. As you can see the registration of Extractor is advantageous for you.


Autor

Author

Nova Software
Vaclav Novacek
Bolesiny 55
33901 Klatovy
Czech Republic

Web: http://www.volny.cz/nova-software
Email: nova-software@volny.cz